| Предыдущий | Следующий |
| NS_E_DRM_LICENSE_INITIALIZATION_ERROR | NS_E_DRM_UNSUPPORTED_ALGORITHM |
NS_E_DRM_CHAIN_TOO_LONG
Что означает NS_E_DRM_CHAIN_TOO_LONG
NS_E_DRM_CHAIN_TOO_LONG (0xC00D284C) — цепочка лицензий превышает поддерживаемую глубину, поскольку восходящая лицензия сама входит в цепочку.
Трассировка должна сохранить KID и хэш заголовка, версию DRM, состояние индивидуализации, идентификаторы цепочки лицензий, результат чтения реестра или конфигурации и первый обратный вызов клиента со сбоем, применительно к состоянию «слишком длинная цепочка лицензий».
Эти данные важны, поскольку отклонено именно состояние «слишком длинная цепочка лицензий».
Что проверить
- проследите связь UplinkKid и подсчитайте уровни корневой и конечной лицензий
- запрошенное действие и точное свойство лицензии, сертификата, профиля, выхода или регистрации, проверяемое при нём
- После изменения причины повторите ту же операцию с теми же исходными данными и убедитесь, что условие «Цепочка лицензий превышает поддерживаемую глубину, поскольку восходящая лицензия сама входит в цепочку» больше не воспроизводится.
Близкие коды
| Код | Чем отличается |
|---|---|
NS_E_DRM_LICENSE_INITIALIZATION_ERROR | механизм DRM не смог инициализировать объект лицензии или подсистему лицензирования для этой операции |
NS_E_DRM_UNSUPPORTED_ALGORITHM | защищённый объект указывает криптографический алгоритм, который не поддерживается клиентом |
Технические ссылки
Нужно найти другой код? Найти другой код состояния или ошибки.
